Emulating the Debug ROM

From z64 wiki
Jump to: navigation, search

Misc Rom info

Rom file name: ZELOOTMA.Z64
Size: 64.0 MB

Getting Legend of Debug to run on Project64

1. Go to Options -> Settings -> ROM Settings (DO THIS WHILE THE GAME IS RUNNING!)

2. Set the following:

  • CPU CORE STYLE: RECOMPILER
  • SELF-MODIFYING CODE METHOD: CHECK MEMORY ADVANCE
  • MEMORY SIZE: 8MB
  • ADVANCED BLOCK LINKING: DEFAULT
  • DEFAULT SAVE TYPE: USE FIRST USED
  • COUNTER FACTOR: 2
  • LARGE COMPILE BUFFER: NO
  • USE TLB: NO
  • REGISTER CACHING: YES
  • DELAY SI INTERRUPT: NO
  • SP HACK: NO
  • RSP AUDIO SIGNAL: NO

3. After all this is done, reset the game, if it does not show up, press generate bitmap, then reset the game again.

4. IF done correctly, you should see the correct graphics, if not see, Trouble with Video. If you do not have any sound, see Trouble with Sound

Getting Legend of Debug to run on Nemu

1. Set memory size to 8MB
2. Use any other plugin than the default
(probably needs more steps but I do not use Nemu)

Getting Legend of Debug to run on wii64

1.set expansion pack to 8 mb if not by defult
2.set frambuffer textures on
3.If you have v1.2 use rice video to avoid texture mapping and z-buffer glitches.
4.If rom crashes after the second load screen or doesn't stop loading after 35 seconds recopy the rom to the /wii64/roms/ directory on your sd card

Troubleshooting

Q: I don't see any video but I hear sound!
A: Change your plugin.

Q: During game, I hear some sorta annoying sound that keeps popping up
A: Go to Sound Options -> Sync Sound to game (or w/e)

Q: I don't hear sound but I have video!
A: Try switching your sound options around